Traffic to the Admin UI of the app has now also been rerouted to AWS. All features of the app are available again as of 5:55 PM EST.
Posted Oct 29, 2025 - 23:16 CET
Monitoring
We’ve rerouted API traffic to AWS to bypass Microsoft Azure Front Door, which continues to experience issues. Public APIs are now available again, and promotions have been fully restored as of 3:30 PM EST. We’re still working on restoring access to the app’s admin interface.
Posted Oct 29, 2025 - 21:23 CET
Identified
The issue has been identified. Discount Ninja’s infrastructure runs on Microsoft Azure and uses Azure Front Door. Microsoft has confirmed a service disruption affecting Azure Front Door and is actively working on a fix.
Posted Oct 29, 2025 - 17:58 CET
Investigating
Access to the admin of the app is affected as well as live promotions. We are currently investigating the issue.